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Course Objectives

➢ Effective use of Business Intelligence (BI) technology Power BI to apply data visualization

To discern patterns and

➢ relationships in the data.

➢ To build Dashboard applications.

➢ To communicate the results clearly and concisely.

➢ To be able to work with different formats of data sets.

Course Outcomes

At the end of the course a student should be able to :

★ Understand How to import data into Power BI.

★ Understand Power BI concepts of Dimensions and Measures.

★ Develop Programs and understand how to map Visual Layouts and Graphical Properties.

★ Create a Dashboard that links multiple visualizations.

★ Use graphical user interfaces to create Frames for providing solutions to real world 

problems.



Lab Problems

1. Understanding Data, What is data, where to find data, Foundations for building Data Visualizations, 

Creating Your First visualization?

2. Getting started with Power BI Software using Data file formats, connecting your Data to Power BI, 

creating basic charts(line, bar charts, Tree maps),Using the Show me panel.

3. Power BI Calculations, Overview of SUM, AVR, and Aggregate features, Creating custom calculations 

and fields.

4. Applying new data calculations to your visualizations, Formatting Visualizations, Formatting Tools 

and Menus, Formatting specific parts of the view.

5. Editing and Formatting Axes, Manipulating Data in Power BI data, Pivoting Power BI data.

6. Structuring your data, Sorting and filtering Power BI data, Pivoting Power data.

7. Advanced Visualization Tools: Using Filters, Using the Detail panel, using the Size panels, 

customizing filters, Using and Customizing tooltips, Formatting your data with colors.

8. Creating Dashboards &amp; Storytelling, creating your first dashboard and Story, Design for different 

displays, adding interactivity to your Dashboard, Distributing &amp; Publishing your Visualization.

9. Power BI file types, publishing to Power BI Online, Sharing your visualizations, printing, and Exporting.

10. Creating custom charts, cyclical data and circular area charts, Dual Axis charts.



LAB PROBLEM-1

Define Understanding Data, What is data, where to find data, Foundations for

Building Data Visualizations, Creating Your First visualization?

OBJECTIVE: Define Understanding Data, What is data, where to find data, Foundations for 

Building Data Visualizations, Creating Your First visualization?

BRIEF DESCRIPTION:

UNDERSTANDING DATA : One of the ways to understand data is to organize and summarize it in a 

meaningful way. This can be done by using various techniques, such as sorting, filtering, grouping, 

aggregating, etc.

OR

The Data Can Understand By Knowing its source, structure any limitations and Clean and preprocess data.

WHAT IS DATA : Data refers to a collection of facts, statistics, or information that can be in various forms,

including numbers, text, images, audio, or any other format that can be processed by computers or analyzed

by humans.

OR

Data is the raw material from which information and knowledge are derived.

WHERE TO FIND DATA : Finding data depends on the specific type of data you're looking for and your 

purpose for using it.

General places and methods to find data:

Government Websites : data.gov

International Organizations : World Bank, and World Health Organization provide extensive datasets on 

various global topics.

Academic Databases : Websites like Harvard Dataverse or UC Irvine's

Data Marketplaces : like Kaggle

Public APIs : Examples include Twitter, Facebook, and Google Maps.

Commercial Data Providers : Examples include Nielsen, Statista, and IHS Markit. 

Open Data Initiatives : OpenData.gov, Open Knowledge International, or Data.gov.uk. 

Social Media and Forums : like Reddit, GitHub, or data-focused forums.



FOUNDATIONS FOR BUILDING DATA VISUALIZATIONS : Building effective data visualizations 

requires a solid foundation in both data analysis and visualization design principles.

Key Foundations :

1. Understand Your Data : Know its source, structure, and any limitations. Clean and preprocess your 

data.ensure it's accurate and ready for visualization.

2. Define Your Audience : Consider who your audience is and what message you want to convey to them 

Your visualization should cater to their needs and comprehension levels.

3. Choose the Right Chart Types : Select appropriate chart types based on the nature of your data and 

the story you want to tell.

4. Simplify and Focus : Keep your visualizations simple and focused on the main message.

5. Use Color Wisely : Ensure that your color choices are accessible and convey meaning effectively.

6. Label and Annotate : Provide clear labels and annotations to help the audience understand the data 

and the significance of what they're seeing.

7. Provide Context : Add context to your visualizations through titles, captions, and explanatory text.

8. Context helps users interpret the data correctly.

9. Interactivity : Consider adding interactive elements to allow users to explore the data on their own.

Interactive elements can enhance engagement and understanding.

10.Data Integrity : Ensure that your data is presented accurately and honestly

11.Consistency : Maintain consistency in design elements such as fonts, colors, and scales across your 

visualizations.Consistency makes it easier for users to compare and interpret data.

12.Storytelling : Tell a compelling story with your data visualizations.Guide the audience through the data

13.Accessibility : Make your visualizations accessible to all users.

14.Testing and Iteration : Test your visualizations with a sample audience to gather feedback and make 

improvements.Iterative design can lead to more effective visualizations.



15. Data Ethics : Consider the ethical implications of your data and visualizations, especially if they involve 
sensitive or personal information.

16. Data Sources and Citations : Clearly attribute data sources and cite references to maintain 

transparency and credibility.

17. Tools and Software : Familiarize yourself with data visualization tools and software such as Power 

BI,Tableau, D3.js, Matplotlib, ggplot2, and others depending on your preferences and needs.

18. Continuous Learning : Stay up-to-date with trends and best practices in data visualization through 

books, courses, and communities dedicated to data visualization.

Creating Your First visualization : Creating First Visualization using POWER BI. Before Creating the 

First Visualization. To Know the How Power BI Desktop works and Install and run Power BI Desktop.

Power BI : Power BI is a collection of software services, apps, and connectors that work together to turn

your unrelated sources of data into coherent, visually immersive, and interactive insights. Your data might

be an Excel spreadsheet, or a collection of cloud-based and on-premises hybrid data warehouses. Power

BI lets you easily connect to your data sources, visualize and discover what's important, and share that

with anyone or everyone you want.

Power BI consists of several elements that all work together, starting with these three basics :

● A Windows desktop application called Power BI Desktop.

● An online software as a service (SaaS) service called the Power BI service.

● Power BI Mobile apps for Windows, iOS, and Android devices.

Power BI Desktop : Power BI Desktop is a free application you install on your local computer that lets 

you connect to, transform, and visualize your data. With Power BI Desktop, you can connect to multiple 

different sources of data, and combine them (often called modeling) into a data model.

How Power BI Desktop works :

➔ Connect to data, including multiple data sources.

➔ Shape the data with queries that build insightful, compelling data models.

➔ Use the data models to create visualizations and reports.

➔ Share your report files for others to leverage, build upon, and share.



Install and run Power BI Desktop : To download Power BI Desktop, go to the Power BI Desktop

download page and select Download Free.

It can also download Power BI Desktop from Microsoft Store Search the Power BI Desktop and Download 

it For Free.

The first time Power BI Desktop starts, it displays the Welcome screen.

From the Welcome screen, you can Get data, see Recent sources, open recent reports, Open other 

reports, or select other links. Select the close icon to close the Welcome screen.

The left side of Power BI Desktop are icons for the three Power BI Desktop views: Report, Data, and

Model, from top to bottom. The current view is indicated by the yellow bar along the left, and you can

change views by selecting any of the icons.

https://powerbi.microsoft.com/desktop
https://powerbi.microsoft.com/desktop


Report view is the default view.



Power BI Desktop also includes the Power Query Editor, which opens in a separate window. In Power

Query Editor, you can build queries and transform data, then load the refined data model into Power BI

Desktop to create reports.

Basic Steps For Creating My First Visualization?

1. Open the Power Desktop app to Create Visualization.

2. Connect the Data Source ( Click the HOME>Get data>Select the exporting Data Format>select the File from 

system>click on open ).



3. The Navigator Show some Display Option of The Data Select the Required Data Sheet and Click on Load.



4. The Loaded Data will show on the right side of the window.

5. Click on Build Visualization and click on required chart and Select the Required Data or Drag and drop

dimensions and measures to explore the data.



6. Your First Visualization Created.

Result : Define Understanding Data, What is data, where to find data, Foundations for 

Building Data Visualizations, Creating Your First visualization has been completed.



LAB PROBLEM-2

Getting started with Power BI Software using Data file formats, connecting your Data

to Power BI,creating basic charts(line, bar charts, Tree maps),Using the Show me

panel.

OBJECTIVE: Getting started with Power BI Software using Data file formats, connecting your Data to 

Power BI,creating basic charts(line, bar charts, Tree maps),Using the Show me panel.

BRIEF DESCRIPTION:

GETTING STARTED WITH POWER BI SOFTWARE USING DATA FILE FORMATS :

What it means to get data from a file :

In Power BI, the data you explore comes from a dataset. To have a dataset, you need some data. This

article focuses on getting data from files.

In Power BI, a dataset is like the engine in your car. The dataset provides the data, metrics, and information

that's displayed in your Power BI dashboard. Your engine, or dataset, needs fuel, and data is the fuel in

Power BI. Your car has a fuel tank that provides gas to the engine. Power BI also needs a fuel tank of data

you can feed your dataset. That fuel tank can be a Power BI Desktop file, Excel workbook file, or CSV file.

In Power BI, you can connect to or import data and reports from these types of files:

★ Microsoft Excel .xlsx and .xlsm files

★ Power BI Desktop .pbix report files

★ Comma-separated value (CSV) .csv files



CONNECTING YOUR DATA TO POWER BI :

Open Power BI Desktop :

Connect to data : To connect to data, from the Home ribbon select Get data.



The Get Data window appears. You can choose from the many different data sources to which Power BI 

Desktop can connect. In this quickstart, use the Excel workbook that you downloaded in

Since this data source is an Excel file, select Excel from the Get Data window, then select the Connect

button.Power BI prompts you to provide the location of the Excel file to which to connect. The downloaded file is

called Financial Sample. Select that file, and then select Open.



Power BI Desktop then loads the workbook and reads its contents, and shows you the available data in the file 

using the Navigator window. In that window, you can choose which data you would like to load into Power BI 

Desktop. Select the tables by marking the checkboxes beside each table you want to import. Import both

available tables.

Once you've made your selections, select Load to import the data into Power BI Desktop.

View data in the Fields pane : Once you've loaded the tables, the Fields pane shows you the data. You 

can expand each table by selecting the arrow beside its name. In the following image, the financials table is 

expanded, showing each of its fields.



Creating Basic Charts(Line, Bar Charts, Tree Maps),Using The Show Me Panel :

Create a line chart :

1. After Connecting the Financial Sample Data to the Power BI Click on Required Category on view Data 

fileds.



2. Convert the chart to a line chart by selecting the Line chart icon in the Visualizations pane:

3. Filter your line chart to show data for the Years. If the Filters pane is collapsed, expand it. Drag the Year 

field from the Data pane to the Filters pane. Drop it under the heading Filters on this visual:

4. Change Advanced filtering to Basic filtering and Optionally, adjust the size and color of the chart's title.



Create a Bar chart’s :

The Bar Chart’s are Basically Three Types They are :

1. Stacked Bar Chart

2. Clustered Bar Chart

3. 100 % Stacked Bar

Chart Steps to Create Bar

Charts :

● First Connect the Dataset Into Power BI.

● Click On Required Data Category For the Chart

● Then Click on the Bar Chart Icon in the Visualization Bar.

●



Tree map :

The following steps create a report and treemap :

● Download the Financial Sample file to your desktop.

● In Power BI Desktop, select File > Open Excel File of Financial

Sample.

● Load The Required Data and its Shows in Power BI View Filed Panel.

● Select The Sales Category on Y-Axis in Data Fields.

● to convert the visualization into a treemap, select Treemap on the Visualizations pane.



● On the Data pane, expand Item and select the Product checkbox.

● On the Data pane, Drag and Drop the Year Checkbox into Details Visualization.



● On Tree Map is created we check each Product Visualized.

By Clicking on each product it will display the values of it.

Result : Getting started with Power BI Software using Data file formats, connecting your Data to Power 

BI,creating basic charts(line, bar charts, Tree maps),Using the Show me panel has been completed.



LAB PROBLEM-3

Power BI Calculations, Overview of SUM, AVR, and Aggregate features, Creating

custom calculations and fields.

OBJECTIVE: Create a Power BI Calculations Overview of SUM, AVR, and Aggregate features, Creating 

custom calculations and fields.

BRIEF DESCRIPTION:

Create a Power BI Calculations Overview of SUM, AVR, and Aggregate features :

What is an aggregate? :

Sometimes you want to mathematically combine values in your data. The

mathematical operation could be sum, average, maximum, count, and so on. When you combine values 

in your data, it's called aggregating. The result of that mathematical operation is an aggregate.

When you create visualizations in Power BI Desktop and the Power BI service, they may aggregate your 

data. Often the aggregate is just what you need, but other times you may want to aggregate the values in 

a different way. For example, a sum versus an average. There are several different ways to manage and 

change the aggregate Power BI uses in a visualization.

First, let's take a look at data types because the type of data determines how, and whether, Power BI can 

aggregate it.

Types of data :

At the most basic level, the data is either numeric or it isn't. Power BI can aggregate 

numeric data using a sum, average, count, minimum, variance, and much more.

Power BI can even aggregate textual data, often called categorical data.

If you try to aggregate a categorical field by placing it in a numeric-only bucket like Values or Tooltips, 

Power BI will count the occurrences of each category or count the distinct occurrences of each category. 

Special types of data, like dates, have a few of their own aggregate options: earliest, latest, first, and last 

Example :

● Units Sold and Manufacturing Price are columns that contain numeric data.

● Segment, CountryRegion, Product, Month, and Month Name contain categorical data.



Change how a numeric field is aggregated :

1. Create a Clustered column chart that uses a measure and a category. In this example, we're 

using Units Sold by Product. By default, Power BI creates a chart that sums the units sold 

(drag the measure into the Value well) for each product (drag the category into the Axis well).

SUM Visualization

2. In the Visualizations pane, right-click the measure, and select the aggregate type you need. In this

case, we're selecting Average.

Visualization aggregated by average.



Ways to aggregate your data :

1. Do Not Summarize. With this option chosen, Power BI treats each value in that field separately and 

doesn't summarize them. Use this option if you have a numeric ID column that Power BI shouldn't sum.

2. Sum. Adds all the values in that field up.

3. Average. Takes an arithmetic mean of the values.

4. Minimum. Shows the smallest value.

5. Maximum. Shows the largest value.

6. Count (Not Blanks). Counts the number of values in that field that aren't blank.

7. Count (Distinct). Counts the number of different values in that field.

8. Standard deviation.

9. Variance.

10.Median. Shows the median (middle) value. This value has the same number of items above and below. If 

there are two medians, Power BI averages them.

For example,using below Data :

Results :

Do Not Summarize : Each value is shown separately

Sum: 427

Average: 85.40

Maximum: 75

Minimum: 95

Count (Not Blanks): 5

Count (Distinct):5

Standard deviation: 6.83

Variance: 46.64

Median:85



Create an Aggregate using a category (text) field :

1. Click on Subject and choose the table Visualization.

2. Select the arrow next to Subject, and change the aggregation from the default Don't summarize to Count 

(Distinct), Power BI counts the number of different Subjects. In this case, there are Five.



3. And if you change the aggregation to Count, Power BI counts the total number. In this case, there are 5 

entries for Subject.

4. Drag the same field (in this case Subject) into the Columns well again. Keep the default aggregation 

Don't summarize. Power BI breaks down the count by Subject.



Creating custom calculations and fields.

By using Contoso Sales Sample Data Creating the calculated 

Column with values related to Sales report Table.

I want to display product categories and subcategories as in single values and in a single column.

It shows things like “ Cell phone - Accessories”,”Cell phones - Smartphones” , and so on.

In the sales sample the Fields are given a ProductCategory and a ProductSubcategory they are each in 

on table.So we can create a calculated column that combines values from these two columns.

Steps :

1. To create a new column in the Product Subcategory table, Click on Product Subcategory and right 

click it will show some options and choose New Column from the menu.

2. When you choose New column, the Formula bar appears along the top of the Report canvas, ready for 

you to name your column and enter a DAX formula.



3. By default, a new calculated column is named Column.You want your column to be more identifiable, 

so while the Column name is already highlighted in the formula bar, rename it by typing FullCategory, 

and then type an equals (=) sign.

4. You want the values in your new column to start with the name in the ProductCategory field. Because 

this column is in a different but related table, you can use the RELATED function to help you get it.

5. After the equals sign, type r. A dropdown suggestion list shows all of the DAX functions beginning with 

the letter R. Selecting each function shows a description of its effect. As you type, the suggestion list 

scales closer to the function you need. Select RELATED, and then press Enter.

6. An opening parenthesis appears, along with another suggestion list of the related columns you can 

pass to the RELATED function, with descriptions and details of expected parameters.

7. You want the ProductCategory column from the ProductCategory table. Select 

ProductCategory[ProductCategory], press Enter, and then type a closing parenthesis.

8. You want colon and spaces to separate the ProductCategories and ProductSubcategories in the new 

values, so after the closing parenthesis of the first expression, type a space, ampersand (&),

double-quote ("), space, colon (:), another space, another double-quote, and another ampersand. Your 

formula should now look like this:



9. Enter an opening bracket ([), and then select the [ProductSubcategory] column to finish the formula.

10. You didn’t need to use another RELATED function to call the ProductSubcategory table in the second 

expression, because you're creating the calculated column in this table. You can enter 

[ProductSubcategory] with the table name prefix (fully qualified) or without (non-qualified).

11.Complete the formula by pressing Enter or selecting the check mark in the formula bar. The formula 

validates, and the FullCategory column name appears in the ProductSubcategory table in the Fields 

Pane.

lookUse your new column in a report : Now you can use your new ProductFullCategory column to 

at SalesAmount by FullCategory.

1. Select or drag the FullCategory column from the ProductSubcategory table onto the Report canvas to create a 

table showing all of the FullCategory names.



2. Select or drag the SalesAmount field from the Sales table into the table to show the SalesAmount for each 

FullCategory.

3. Calculated Column has been Created in Field.

Result : Power BI Calculations, Overview of SUM, AVR, and Aggregate features, Creating custom 

calculations and fields Completed.



LAB PROBLEM-4

Applying new data calculations to your visualizations, Formatting Visualizations,

Formatting Tools and Menus, Formatting specific parts of the view.

OBJECTIVE:Applying new data calculations to your visualizations, Formatting Visualizations, Tools and

Menus, Formatting specific parts of the view.

BRIEF DESCRIPTION:

Applying New Data Calculations to Visualizations :

1. Drag and Drop Calculated Fields:

To apply your newly created calculated fields to a visualization, simply drag and drop them onto the

appropriate shelves in your worksheet. For example, you can drag a calculated field to the Rows or

Columns shelf.



2. Filter with Calculated Fields:

Create filters using calculated fields to control which data points are displayed in your visualization. You can use 

calculated fields to filter by specific criteria, such as a calculated date range,category or value range.

Formatting Visualizations :

Power BI provides formatting options to make your visualizations more appealing and informative:

Format Pane:

On the Right side of the Power BI interface, you'll find the Format pane. It allows you to

format various aspects of your visualization, such as fonts, colors, lines, shading, and borders. Simply

select the element you want to format and use the options in the Format pane to make changes.



Formatting Tools and Menus :

Power BI provides several formatting tools and menus to help you refine the appearance of your

visualizations:

Format Menu:

The Format menu at the top of the Power BI interface provides access to various formatting options,

including font styles, shading, borders, alignment, and more. You can use this menu to format text, labels,

and other elements.

● Legend

● X-axis

● Y-axis

● Data colors

● Data labels

● Total labels

● Shapes

● Plot area

● Title

● Background

● Lock aspect

● Border

● Shadow

● Tooltip

● Visual header

● Shapes

● Position

● Zoom

Change colors in a visual :

Let’s walk through the steps necessary to customize colors on a visualization.

1. Select a visualization to make it active.

2. Select the paint brush icon to open the Formatting tab. The Formatting tab displays all the formatting 

elements available for the selected visual.



4.Open Columns Tab select the color specific category wise.

Apply a style to a table :

Some Power BI visualizations have a Style option. One click applies a full set of formatting options to your 

visualization, all at once.

1. Select a table or matrix to make it active.

2. Open the Formatting tab and select Style presets.



Even after you apply a Style, you can continue formatting properties, including color, for that visualization.

Change axis properties :

It’s often useful to modify the X-axis or the Y-axis. Similar to working with colors, you can modify an axis by 

selecting the down-arrow icon to the left of the axis you want to change, as shown in the following image.



The following example illustrates making the following formatting changes to the Y axis:

● Move the labels to the right side of the visualization.

● Change the starting value to zero.

● Change the label font color to black.

● Increase the label font size to 12.

● Add a Y-axis title.

Add data labels :

Here is the before picture.

Here is the after picture.

Result : Applying new data calculations to your visualizations, Formatting Visualizations, Formatting Tools 

and Menus, Formatting specific parts of the view is completed.



LAB PROBLEM-5

Editing and Formatting Axes, Manipulating Data in Power BI data, Pivoting Power

BI data.

OBJECTIVE: Editing and Formatting Axes, Manipulating Data in Power BI data, Pivoting Power BI data.

BRIEF DESCRIPTION:

Editing and Formatting Axes :

Before customize or Edit and Formatting Axes your visualization, you have to build it.

1. In Power BI Desktop, open the Retail Analysis sample.

2. Add insert new page by clicking the At the bottom, plus icon.

3. From the Visualizations pane, select the any chart icon. This adds an empty template to your report 

canvas.

4. To set the X-axis values, from the Fields pane, select Time > FiscalMonth.

5. To set the Y-axis values, from the Fields pane, select Sales > Last Year Sales and Sales > This Year 

Sales > Value.



Now we can customize your X-axis. Power BI gives you almost limitless options for formatting your

visualization.

Customize the X-axis :

There are many features that are customizable for the X-axis. You can add and modify the data labels and

X-axis title. For categories, you can modify the width, size, and padding of bars, columns, lines, and areas.

And for values, you can modify the display units, decimal places, and grid lines.

Customize the X-axis labels :

The X-axis labels display below the columns in the chart. Right now, they're light gray, small, and difficult to

read. Let's change that.

) to1. In the Visualizations pane, select Format (the paint brush icon 

reveal the customization options.

2. Expand the X-axis options.

3. Move the X-axis slider to On.



4. Format the text color, size, and font:

● Color: Select black

● Text size: Enter 14

● Font family: Select Arial Black

Customize the X-axis title :

When the X-axis title is On, the X-axis title displays below the X-axis labels.

1. Start by turning the X-axis title to On.



2. The Title will display on the x-axis path.

3. Format the title text color, size, and font:

● Title Color : Select Orange

● Title text size : 16

Note: we can change the Title Manually also.



Customize the Y-axis labels :

1. Expand the Y-Axis options.

2. Move the Y-Axis slider to On.

3. Format the text color, size, and font:

● Color: Select black

● Text size: Enter 12

● Display units: Select Millions

Customize the Y-axis Title:

We can customize the Y-axis Title by Clicking on the Title On option.when it turns ON the Title will display 

on visualization on the left side of the chart.we can change the color and text size.



Manipulating Data in Power BI data:

The Manipulating Data in Power BI data by changing the Data type, Data updating & Removing the 

Duplicates of the Data.

1. First Import the Data Manipulating data Power BI file( Showed on Below Data ).

2. Transform Data into Editing ( Power Query Editor ).

3. When we click on a column the Power BI automatically shows its Data Type.



4. By choosing a Date Column we can change the Date into Different Format’s Like Year,Month,Date by 

using transform tab > Date & Time column > Date.

5. Then click on month only the date column shows month instead of full date and the Data is 

manipulated.

Data Manipulation By updating The Imported file Data

1. First open the excel or csv file that are imported for maniputated sample file.



2. Then Change or update the Data in the file.I’m Duplicating the last row data into 4 times.

3. Then save the file and open the Power BI Previous saved Manipulated sample file and go to 

Editor mode and check whether the Data is updated as per change is done on the sample file.

4. The Changes have been performed.

5. The data is manipulating and then removing duplicates from the click on segment column.



6. The Duplicate data has been removed from the data.

Pivoting Power BI data :
Power Query in Power BI provides very effective functionality to pivot and unpivot columns. For the pivot

functionality you turn rows to columns and for the unpivot functionality the inverse is true where columns

are transformed into rows.

Power BI Pivot :

1. We will be working with the following data set:



2. We would like to transform the months, currently rows to columns and aggregate the Sales, the value

column, per month. This means that we will have a column per month. To do this go into Power Query,

select Transform and then select Pivot Column.

3.The Pivot dialog box will prompt you to enter the values columns. In this example, we will use Sales.

4.When you press OK the following pivoted result will appear.

5.you will notice that if the data is not available that cell is showing as null.



6. The Power BI Desktop Given some Advanced options also they are used to modify the data as you 

want to.

7.The Pivoting of the Data is completed.

Result : Editing and Formatting Axes, Manipulating Data in Power BI data, Pivoting Power BI data has 

been completed.



LAB PROBLEM-6

Structuring your data, Sorting and filtering Power BI data.

OBJECTIVE: Structuring your data by Sorting and filtering Power BI data.

BRIEF DESCRIPTION:

Set the column to use for sorting :

To set a different column to sort by in Power BI Desktop, both columns need to be at the same level of

granularity. For example, to sort a column of month names correctly, you need a column that contains a

number for each month. The sort order will apply to any visual in the report that contains the sorted

column. In the following example, the months are sorted alphabetically, but they should be sorted

chronologically.

1. Select the column that you want to sort, in this case, Month. Note that the months in the visual are 

sorted alphabetically. In the Fields pane, the Column tools tab becomes active.



2. Select Sort by Column, then select the field you want to sort the other field by, in this case, Month 

Number.

3. The visual automatically sorts chronologically by the order of months in a year.



Set the column to use for filtering :

This article explains how to add a visualization filter, page filter and report filter.You need to be able to

edit a report to add filters.The examples in this article are in the Power BI Desktop.

Levels of filters in the Filters Pane :

Power BI Desktop the Filters pane displays along the right side of the report canvas. If you don't see

the Filters pane, select the ">" icon from the upper-right corner to expand it.

You can set filters at three different levels for the report:

● The visual level.

● The page level.

● The report level.

This article explains how to set the different levels.

Add a filter to a visual :

Visuals have two different kinds of filters. The fields that are in a visual are automatically filters for that

visual. As the report designer, you can identify a field that isn't already the visual, and add that field

directly to the Visual level filters bucket.

By the way, this article uses the Retail Analysis sample, if you'd like to install it and follow along. Install

the Retail Analysis sample.

1. In Power BI Desktop, select the Report icon.



2. Open the Visualizations, Filters, and Fields panes, if they're not already open.

3. Select a visual to make it active. In this case, it's the scatter chart on the Overview page. All the

fields in the visual are in the Visualizations pane. They're also listed in the Filters pane, under

the Filters on this visual heading.

4. From the Fields pane, select the field you want to add as a new visual-level filter, and drag it into 

the Filters on this visual area. In this example, we drag Category to Add data fields here.



Notice Category is not added to the visualization itself.

5. Select Kids. The scatter chart is filtered, but the other visuals stay the same.



If you save your report with this filter, report readers can interact with the Category filter in the Reading 

view, selecting or clearing values.

If you drag a numeric column to the filter pane to create a visual-level filter, the filter is applied to the 

underlying rows of data. For example, adding a filter on the UnitCost field and setting it where UnitCost

> 20 would only show data for the Product rows where the Unit Cost was greater than 20, regardless of 

the total Unit Cost for the data points shown in the visual.

Add a filter to an entire page :

1. In Power BI Desktop, open the Retail Analysis report.

2. Select the Report icon, then go to the District Monthly Sales page.

3. Open the Visualizations, Filters, and Fields panes, if they're not already open.

4. From the Fields pane, select the field you want to add as a new page-level filter, and drag it to Add data 

fields here in the Filters on this page area. In this case, we added a District Manager.



5. Select the values you want to filter and set either Basic or Advanced filtering controls.All the

visualizations on the page are redrawn to reflect the change.If you save your report with the filter,

report readers can interact with the filter in Reading view, selecting or clearing values.

Add a report-level filter to filter an entire report

1. In Power BI Desktop, select the Report icon.

2. Open the Visualizations and Filters pane and the Fields pane, if they're not already open.

3. From the Fields pane, select the field you want to add as a new report-level filter, and drag it into the 

Report level filters area.

4. Select the values you want to filter.

The visuals on the active page, and on all pages in the report, change to reflect the new filter. If you

save your report with the filter, report readers can interact with the filter in the Reading view, selecting

or clearing values.

5. Select the back arrow to return to the previous report page.

Reset to default :
Because filters persist, when you navigate away from the report Power BI retains the filter, slicer, and

other data view changes that you've made. So you can pick up where you left off when you return to

the report. If you don't want your filter changes to persist, select Reset to default from the top menu

bar.

Keep in mind that as the report creator, whatever filters you save with the report become the default 

filter state for all your report readers. When they select Reset to default, that's what they return to.

Result : Structuring your data, Sorting and filtering Power BI data Completed.



LAB PROBLEM-7

Advanced Visualization Tools: Using Filters, Using the Detail panel, using the Size

panels,customizing filters, Using and Customizing tooltips, Formatting your data

with colors.

OBJECTIVE: Advanced Visualization Tools: Using Filters, Using the Detail panel, using the Size 

panels,customizing filters, Using and Customizing tooltips, Formatting your data with colors.

BRIEF DESCRIPTION:

Filters

While the Filters pane search feature is on by default, you can also choose to turn it on or off by selecting 

Enable search for Filters pane in the Report settings of the Options dialog.



Restrict changes to filter type :

Under the Filtering experience section of Report settings, you can control if users can change the filter type.

Apply filters button :

In Power BI Desktop, you can add a single Apply button to the filter pane, allowing you and your

end-users to apply all filter modifications at once. Having this button is useful if you want to defer

applying filter changes. You only have to wait once, after you're ready to apply all the filter changes to the

report or visuals.

Turn on the Apply button :

You can set this feature at the report level, only in Power BI Desktop. However, the feature is off by 

default.

● Go to File > Options and settings > Options > Query reduction.

● Select Add a single Apply button to the filter pane to apply changes at once.



Format the Apply button :

Currently, you can control some of the formatting for the Apply text for the button. In the Filter pane section 

of the Format pane, set these options:

● Under Text

Font controls font family

Text and icon color controls text color.

● Under Header

Header text size controls text size.



Sort the Filters pane :

Custom sort functionality is available in the Filters pane. When creating your report, you can drag and drop 

filters to rearrange them in any order.

The default sort order for filters is alphabetical. To start custom sort mode, drag any filter to a new position.

You can only reorder filters within the level they apply to. For example, you can change the order of the

visual-level filters within the visual-level section of the Filters pane.

Rename filters :

When you're editing the Filters pane, you can double-click the title to edit it. Renaming is useful if you want

to update the filter card to make more sense for your end users. Renaming the filter card doesn't rename

the display name of the field in the fields list. Renaming the filter card just changes the display name used

in the filter card.



Customizing tooltips :

Tooltips are an elegant way of providing contextual information and detail to data

points on a visual. The following image shows a tooltip applied to a chart in Power BI Desktop. You can

customize tooltips in Power BI Desktop and in the Power BI service.

When a visualization is created, the default tooltip displays the data point's value and category. There are

many instances when customizing the tooltip information is useful. Customizing tooltips provides context

and information for users viewing the visual. Custom tooltips enable you to specify more data points that

display as part of the tooltip.

How to customize tooltips :

To create a customized tooltip, in the Fields well of the Visualizations pane, drag a

field into the Tooltips bucket, shown in the following image. In the following image, three fields have been

placed into the Tooltips bucket.



Once tooltips are added to Tooltips, hovering over a data point on the visualization shows the values for 

those fields.

Customize tooltips with aggregation or quick measures : You can further customize a tooltip by 

selecting an aggregation function. Select the arrow beside the field in the Tooltips bucket. Then select from 

the available options.



In Power BI Desktop, you can also select a quick measure. Read about creating quick measures in 

Power BI Desktop.

There are many ways to customize tooltips, using any field available in your semantic model, to convey 

quick information and insights to users viewing your dashboards or reports.

Allow tooltips to auto-scale (preview) :

You can change a report setting so that tooltips adjust their size automatically based on the canvas size.

In Power BI Desktop, select File > Options and settings > Options.

Under Current file, select Report settings, and select Tooltip size is affected by canvas size.



Formatting your data with colors :

Open a report in Report view.

When the Filters and Visualizations panes appear along the right side of the report canvas, you’re ready to 

start customizing. If the panes don't appear, select the top-right arrows to open them.



Apply a theme :

In Power BI Desktop, you can apply design changes to your entire report, such as using corporate colors,

changing icon sets, or applying new default visual formatting. When you apply a report theme, all visuals in

your report use the colors and formatting from your selected theme. To learn more, see Use report themes

Here, the Innovate theme has been applied to the report.

Change the color of a single data point :

Sometimes you want to highlight one particular data point. Perhaps it’s a sales figure for the launch of a

new product, or increased quality scores after launching a new program. With Power BI, you can highlight a

particular data point by changing its color.



The following visualization ranks units sold by product segment.

Imagine you want to call out the Extreme segment to show how well this brand new segment is 

performing, by using color. Here are the steps:

Expand the Columns card and turn on Show all to display the colors for each data element. You can now 

modify any of the data points.



Set Extreme to orange.

Once selected, the Extreme data point is a nice shade of orange, and certainly stands out.

If you expect to add new columns to the chart, and want to maintain the same color scheme, be sure to set 

the Default color to blue.

Even if you change visualization types, then return, Power BI remembers your selection and keeps Extreme 

orange.



Base the color of data points on a value :

To change color based on a value, select a visualization to make it active. Open the Format pane by 

selecting the paint brush icon and then choose the Colors card. Next to Default, select the fx icon.

In the Default color dialog box, use the dropdowns to identify the fields to use for conditional formatting. In 

this example, we've selected the Count of Product field and selected light blue for the Lowest value and 

dark blue for Highest value.



You can also format the color of the visual using a field that isn't part of the visual. In the following image,

% Units Market Share SPLY is being used.

As you can see, although we've sold more units of Productivity, Convenience, and Extreme (their columns 

are higher), Moderation has a larger % Units Market Share SPLY (its column has more color saturation).



Customize the colors used in the color scale :

You can also change the way the values map to these colors. In the following image, the colors for 

Minimum and Maximum are set to red and green, respectively.

In this first image, notice how the bars in the chart reflect the gradient shown in the bar. The highest

value is green, the lowest is red, and each bar in between is colored with a shade of the spectrum

between green and red.

Now, let’s see what happens if we provide numeric values in the Minimum and Maximum value boxes. 

Select Custom from the drop-down boxes for both Minimum and Maximum, and set Minimum to 250, and 

set Maximum to 600.



Add color to table rows :

Tables and matrices offer many options for color formatting.

One of the quickest ways to apply color to a table or matrix is to open the Format pane and select Style 

presets. In the image below, we've selected Bold header flashy rows.

Experiment with other color formatting options. In this image, we've changed the background color under 

Column headers and changed both the Background color and Alternate background color for the Values 

(rows).

Result : Knowing and practical of Advanced Visualization Tools: Using Filters, Using the Detail panel, using 

the Size panels,customizing filters, Using and Customizing tooltips, Formatting your data with colors has 

been Completed.



LAB PROBLEM-8

Creating Dashboards &amp; Storytelling, creating your first dashboard and

Story, Design for different

displays, adding interactivity to your Dashboard, Distributing &amp; Publishing

your Visualization.

OBJECTIVE: Creating Dashboards &amp; Storytelling, creating your first dashboard and Story, Design

for different displays, adding interactivity to your Dashboard, Distributing &amp; Publishing your

Visualization.

BRIEF DESCRIPTION:

Storytelling : Tell a compelling story with your data visualizations.Guide the audience through the 

data.

Creating your first dashboard and Story :
You've read Introduction to dashboards in Power BI, and now you want to create your own. There are many 

ways to create a dashboard. For example, you can create a dashboard from a report, from scratch, from a 

semantic model, or by duplicating an existing dashboard. In this article, you create a quick and easy 

dashboard that pins visualizations from an existing report.

After you complete this article, you'll understand:

● The relationship between dashboards and reports.

● How to pin tiles.

● How to navigate between a dashboard and a report.

Note : Dashboards are a feature of the Power BI service, not Power BI Desktop. You can't create 

dashboards in the Power BI mobile apps, but you can view and share them there.



DashBoard and Story Creation :

Example : “Exploratory Analysis Report: Superstore Sales Data” 

Steps to Create a Dashboard :

1. Open the Power BI Software

2. Import the dataset (Excel File) into Power BI software.

3. Set the Background theme for better Visualization.

4. First add two slicer charts in the visualization bar and select the data “category” and “ Region”.

5. Add two blank Gauge charts by clicking the Gauge icon in the build Visual tab. Set it one for “Total 

sales” and one for “Total Profit”.

6. Add two blank Pie Charts and set the data one into “Total sales by category” ( By clicking on Category 

in Legend and Sales in Values ). And one Pie chart for “Total Profit by Category”( Category in Legend 

and Profit in Values ).



7. Insert one Stacked area chart into visualize the “Total sales and Total Profit by Month” ( X-axis = Order 

Date and Month and Y-axis = Sales , Profit)

8. Add Blank Map chart and select the data sales and state.

9. Insert two clustered Column charts, select one chart and insert data on it by clicking X-axis = sales & 

Y-axis = Sub category and set filter of sub-category top 5 and it shows the “High total sales of

sub-category” in another chart set same data fields but filter it bottom 5 it shows the “Low Total sales of 

sub-category”



10. Finally the Sales analysis of a superstore Dashboard was created.

Story of The DashBoard :

Introduction :

In this exploratory analysis, we delve into the sales data of our superstore, aiming to uncover key insights and 

potential areas for improvement. The dashboard and analysis are done with Microsoft PowerBI.

Performance Against Expected Values :

We begin by comparing Total Sales and Total Profit against the company's expected values. This provides an 

overview of our performance relative to set benchmarks.

Category Analysis: Sales vs. Profit :

A closer look at our product categories reveals intriguing findings:

● Technology 💻 : Highest in both sales and profit (51%).

● Furniture🪑 : Second in sales but only 6% profit.

● Office Supplies📌 : Lowest sales, yet yields 43% profit.



Top and Bottom Selling Items :

Identifying our top 5 and bottom 5 selling items within sub-categories sheds light on product popularity and 

areas needing attention.

Monthly Sales Trends :

Examining monthly sales data helps us pinpoint peak and off-peak periods. We also 

analyze the margin between total sales and returns: Notably high margin in Q4 (Oct-Dec) suggests a 

strategic focus on this quarter for increased profitability.

Geographic Sales Analysis :

Visualizing sales by state using bubbles highlights regional disparities:

California and New York stand out with high sales, potentially due to their larger populations and higher tech 

consumption.

Low sales states present opportunities for targeted advertising and tailored product offerings.

Recommendations :

From our analysis, several actionable insights emerge:

● Furniture Sales 🪑 : Despite high sales, profitability is low. Consider product innovation and

price adjustments to increase profit margins.

● Product Focus 🔗 : Allocate resources towards top-selling items for sales growth, while reevaluating the

bottom 5 for potential discontinuation.

● Q4 Strategy 🪑 : Develop a Q4 sales strategy to capitalize on the high margin between total sales and

returns.

● Geographical Targeting🌎 : Implement targeted advertising strategies based on regional sales

trends tomaximize sales potential.

Publishing your Visualization.

1. In Power BI Desktop, on the Home tab, click or tap Publish.

2. If you're not already signed in to the Power BI service, enter an account, then click or tap Sign in.

3. Enter a password, then click or tap Sign in.



4. Choose a destination for the report, then click or tap Select. We recommend publishing to a group 
workspace to simplify access to the report in SharePoint. In this case, we are publishing to the Project 

Management group workspace. For more information, see Collaborate in your Power BI app 
workspace.

5. After publishing completes, click or tap Open 'project-analysis.pbx' in Power BI.

Result : Creating Dashboard and Story, Design for different displays, adding interactivity to your 
Dashboard, Distributing &amp; Publishing your Visualization has been completed.



LAB PROBLEM - 9

Power BI file types, publishing to Power BI Online, Sharing your visualizations, 

printing, and Exporting.

OBJECTIVE: Power BI file types, publishing to Power BI Online, Sharing your visualizations, printing, 

and Exporting.

BRIEF DESCRIPTION:

Power BI file types :

In Power BI, you can connect to or import data and reports from these types of files:

● Microsoft Excel .xlsx and .xlsm files

● Power BI Desktop .pbix report files

● Comma-separated value (CSV) .csv files

Publishing to Power BI Online :

The Power BI report web part for SharePoint Online allows you to embed interactive Power BI reports in 

SharePoint Online pages.

When you use the Embed in SharePoint Online option, the embedded reports respect all item permissions 

and data security through row-level security (RLS), so you can easily create secure internal portals.

Requirements :

For Embed report in SharePoint Online reports to work:

● The Power BI web part for SharePoint Online requires Modern Pages.

● To use an embedded report, users must sign in to the Power BI service to activate their Power BI license.

● To embed a web part in SharePoint Online, you need a Power BI Pro or Premium Per User (PPU) 

license.

● Users with a free Fabric license can view a report that's hosted in a Power BI Premium capacity (EM or P 

SKU) or Fabric F64 or greater capacity.

Embed your report :

To embed your report into SharePoint Online, you need to get the report URL and use it with SharePoint 

Online's Power BI web part.

Get a report URL

1. Open a report in the Power BI service.

2. On the File menu, select Embed report > SharePoint Online.\



3. Copy the report URL from the dialog box.

Add the Power BI report to a SharePoint Online page

1. Open the target page in SharePoint Online and select Edit.



Or, in SharePoint Online, select Pages > + New > Site Page to create a new modern site page.

2. Select the + in New dropdown menu. In the Data analysis section, select Power BI web part.

3. Select Add report.

4. Paste the previously copied report URL into the Power BI report link field. The report loads automatically.



5. Select Publish to make the change visible to your SharePoint Online users.

6. Grant access to reports : Embedding a report in SharePoint Online doesn't automatically give users permission to 

view the report - you need to set view permissions in Power BI.

Share a dashboard :

In a list of dashboards, or in an open dashboard, select Share

Then in the Share dashboard dialog, you'll see the option to grant users or groups direct access to the 
dashboard:

Enter the name or email address of the user or group, optionally type a message, and select Grant access.



Similar to report sharing, you can specify if you want to grant users the following permissions as well:

● Reshare permissions (included by default) – allows recipients to share the dashboard to others

● Build permissions (included by default) – allows recipients to build content with the data associated with 
the dashboard.

You can share the dashboard with guest users whose addresses are outside your organization, but guest 

users can't reshare dashboards. Read more about sharing outside your organization in this article.

Manage permissions to a dashboard :

To manage permission to the dashboard, select the More options menu (. . .) in the upper right of the 
Share dashboard dialog, and then select Manage permissions:

The Manage permissions pane opens, where you can see who has direct access. Select the plus icon (+) 
to grant more users direct access to the dashboard.

For more access management capabilities, select the Advanced option in the footer of the Manage 
permissions pane. On the management page that opens, you can:



● View and manage who has Direct access and grant people direct access
● View and manage Pending access requests and invitations

● View and manage Related content
● Apply Filters or Search for specific people

To remove a user's access to the dashboard, select the ellipsis (...) next to that user's permissions and 
select Remove access:

In the Remove access dialog, decide if you also want to remove access to related content, such as reports 
and semantic models. It's best to also remove access to related content; otherwise, the related content 

may not display properly.



Print a dashboard :

1. Open the dashboard that you'd like to print.
2. In the upper left corner, select File > Print this page.

3. If your report has a sensitivity label, decide whether you should print the report or not.

4. Adjust your print settings.
5. Select Print.

APPLIES TO : Power BI service for business users Power BI service for designers & developers Power
BI Desktop Requires Pro or Premium license

Print an entire dashboard, a dashboard tile, a report page, or a report visual from the Power BI service. If
your report has more than one page, you need to print each page separately. Printing isn't available from
Power BI Desktop.



Export reports from Power BI to PDF :

You can export your Power BI reports to PDF easily, both from the Power BI service and from Power BI 
Desktop. Exporting to PDF is one way to share or print reports.

Export to PDF from Power BI Desktop

1. In Desktop, open the .pbix file that contains the report you want to export.
2. After the report opens, select File > Export > Export to PDF.

3. Report pages that are currently not visible, such as any tooltips or hidden pages, aren't exported to the 
PDF file.

4. While the export is being processed, a dialog appears that lets you know that the export process is
underway. The dialog remains on the screen until the export process completes. During the export
process, all interaction with the report being exported is disabled. The only way to interact with the

report is to wait until the export process completes, or to cancel the export.
5. The exported PDF displays in your default PDF viewer (typically Adobe Acrobat Reader or a browser).

Result : To learn about Power BI file types, publishing to Power BI Online, Sharing your visualizations, 
printing, and Exporting is Completed.



LAB PROBLEM - 10

Creating custom charts, cyclical data and circular area charts, Dual Axis charts.

OBJECTIVE: Creating custom charts, cyclical data and circular area charts, Dual Axis charts.

BRIEF DESCRIPTION:

Circular area chart :
Area charts emphasize the magnitude of change over time, and can be used to 

draw attention to the total value across a trend. For example, data that represents profit over time can be 

plotted in an area chart to emphasize the total profit.

When to use a basic area chart :

Basic area charts are a great choice:

● to see and compare the volume trend across a time series.

● for an individual series representing a physically countable set.

Prerequisites :
To follow this tutorial in Power BI Desktop, download the Retail Analysis Sample PBIX file.

If you'd like to use the Power BI service, download the Retail Analysis PBIX file, and then upload it to

a workspace in the Power BI service.



Create a basic area chart :

These steps will help you create an area chart that displays this year's sales and 

last year's sales by month.

1. In Power BI Desktop, open the Retail Analysis Sample PBIX file in the report view . In the Power BI 

service, open the Retail Analysis Sample PBIX file and select Edit.

2. Select to add a new page.

3. From the Fields pane, select Sales > Last Year Sales, and This Year Sales > Value.

4. Convert the chart to a basic area chart by selecting the Area chart icon from the Visualizations pane.



5. Select Time > FiscalMonth to add it to the Axis well.

6. To display the chart by month, select the ellipses (top right corner of the visual) and choose Sort by > 

FiscalMonth. To change the sort order, select the ellipses again and select either Sort ascending or Sort 

descending.

Highlighting and cross-filtering :

For information about using the Filters pane, see Add a filter to a report.

To highlight one particular area in your chart, select that area or its top border. Unlike other visualization 

types, if there are other visualizations on the same page, highlighting a basic area chart doesn't

cross-filter the other visualizations on the report page. However, area charts are a target for cross-filtering 

triggered by other visualizations on the report page.

1. Try it out by selecting your area chart and copying it to the New Stores Analysis report page (CTRL-C 

and CTRL-V).

2. Select one of the shaded areas of the area chart and then select the other shaded area. You'll notice no 

effect on the other visualizations on the page.

3. Now select an element. Notice the effect on the area chart—it gets cross-filtered.



Dual Axis chart :

Create a combo chart with two axes

In this task, we'll compare gross margin and sales.

1. Create a new line chart that tracks Gross Margin Last Year % by FiscalMonth.

2. Select the ellipsis to sort it by FiscalMonth, then select the ellipsis again and choose Sort axis > Sort 

ascending.

3. In January GM% was 35%, peaked at 45% in April, dropped in July and peaked again in August. Will we 

see a similar pattern in sales last year and this year?

4. Add This Year Sales > Value and Last Year Sales to the line chart. The scale of Gross Margin Last Year

% is much smaller than the scale of Sales which makes it difficult to compare.



5. To make the visual easier to read and interpret, convert the line chart to a Line and stacked column chart.

6. Drag Gross Margin Last Year % from Column y-axis into Line y-axis.

7. Power BI creates two axes, thus allowing the semantic models to be scaled differently; the left 

measures sales dollars and the right measures percentage. And we see the answer to our question: 

yes, we do see a similar pattern.



Add titles to the axes :

1. Select the paintbrush icon to open the Formatting pane.

2. Set Y-axis to On, then select the down arrow to expand the Y-axis options.

3. Set Y-axis > Values > Display units to Millions.

4. Set Y-axis > Title to On, then set Style to Show title only

5. Set Secondary y-axis to On to display options for formatting the line chart portion of the combo chart.

6. Under Secondary y-axis, set Title to On.

Your combo chart now displays dual axes, both with titles.



7. Optionally, modify the text font, size, and color and set other formatting options to improve the display 

and readability of the chart.

Result :

Creating The cyclical data and circular area chart, Dual Axis chart has been completed.


